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Conditions of use 
 
ParticleCO analysis program was developed to count particles in microscopy 
applications. However, it can also be used in any other imaging application in which 
the counting of particles in the stack of images is of interest.  
 
 
Celica retains Copyright and all rights are reserved. Unregistered use of ParticleCO 
is a violation of International Copyright Laws. Users may not rent or lease 
ParticleCO.  
 
 
 
The ParticleCO is provided “as is” and with no warranties of any kind. The content of 
this User’s guide is available for informational use only and is subject to change 
without notice. Celica assumes no responsibility or liability for any errors or 
inaccuracies that may appear in the ParticleCO software or the user’s guide.  
 
 
 
 
 
 
 
Celica, d.o.o.  
Stegne 21c 
SI-1000  
Ljubljana 
Slovenia 
 
 
phone: +386 (0)1 51 310 61 
fax: +386 (0)1 51 123 15 
e-mail: celica@siol.net 
 
 
 

URL: http://www.celica.si 
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1. Introduction and software installation 

1.1 Introduction 
ParticleCO is a particle counting software which can be used to count objects in three 
dimensional stacks of images. ParticleCO program was developed to count particles 
in microscopy applications. However, it can also be used in any other imaging 
application in which the counting of particles in the stack of images is of interest.  
 
ParticleCO is a menu driven program. It represents a powerful aid for rapid counting 
of particles in images.  
 
ParticleCO provides tools to visualize results in 3D charts. The selected coordinates 
of a particle position can be visualized.  
 

1.1.1 Major features 

• Manual counting of up to three different particle types in a 3D stack of 
images. 

• Verification of particle coordinates and interactive correction of coordinates. 
• Visualization of positions in 2D and 3D charts. 
• Zoom of image series to a specified region. 
• Intuitive user interface. 
• Export of coordinates to an ASCII file. 
• Selected visualization of one, two or three channels of RGB color image.  
• Export of images together with marked positions to an AVI file. 

 

1.2 Installing the ParticleCO software 
Once you have closed all other Windows applications, you are ready to install 
ParticleCO. 
 
• Insert the ParticleCO installation CD into your CD drive or open the folder with the 

downloaded ParticleCO software. 
• Double click the”Install.exe” icon.  
• Installation procedure will start and all ParticleCO program files will be copied to 

your hard disk. The setup program will create the C:\ ParticleCO folder. A 
ParticleCO program group containing the ParticleCO program icon will be 
created.  

• Start ParticleCO by clicking the icon.  
 

1.3 Hardware requirements 
ParticleCO is designed to run on Windows NT®, Windows 2000® and Windows XP®.  
To run ParticleCO you will require an IBM-PC compatible computer with at least 
Intel® Pentium III® class processor (higher recommended), minimum 128 MB RAM 
(256 MB RAM or more recommended) and an adequate hard disk capacity. A VGA 
or higher resolution video interface card and monitor with at least 800x600 resolution 
is recommended.  
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2 Using ParticleCO 

Quick reference 

Import images 

To start working with ParticleCO, first import a series of images. Click Import images 
on the File menu. Input the number of images to import and input the path and name 
of the folder where the series of images is stored. To browse for the location of the 
folder, click the Browse button. When ready, press the Load button. If you do not 
input the number of images to import, all images in the folder will be imported. The 
images should be in the 24-bit RGB color tagged image file format (TIFF). 
 

Manual determination of particle position 

To start counting particles on images, use the Enter key. A crosshair will appear on 
the screen. With the left-mouse-click determine the position of the particle. 
Coordinates will be stored and the circular mark will appear on the image. You can 
reposition the circular mark by pressing Enter key again. To mark next particle, press 
Right arrow key on the keyboard. The particle number on the display will be 
automatically increased by one and a crosshair will appear. Please note that key 
commands are available only if the image window is active (click on the image to 
activate it). Up Arrow will proceed to next image in the stack. Marks of earlier 
marked particle positions will remain on the screen, but will be dimmer.  
 

Saving trajectories 

When you have finished with or have discontinued the particle counting, you can 
save coordinates of particle positions in an ASCII text file. This file is used for further 
counting in the same set of images, and for analysis by any other software 
supporting the import of text files. To save trajectories use the Save positions file 
command in the File menu.  
 

Viewing 3D positions of particles 

ParticleCO provides tools to visualize particle positions. By pressing the Visualize 
3D button, a 3D chart will be opened. Please see chapter 2.2.6 View Menu for 
details.  
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2.1 Toolbar 
The slider is used to select an individual image from a 
series of images. By clicking the Up or Down scroll arrow, 
the next image in series will be displayed. By clicking 
above or below the scroll box, software will skip nine 
images and display the tenth image. To scroll to a specific 
image, drag the scroll box, or type the number of the 
image in the upper text box with white background and 
press Enter.  
 
Select particle No. is the edit menu where any particle 
number can be selected. The label of the current particle 
corresponds to the entered particle number.  
 
Red particle, Green particle and Yellow particle radio 
button will assign color to particles. This may be used to 
distinguish up to three different particle types.  
 
By pressing the Visualize 3D button, a three-dimensional 
chart with particle positions will open. In the Tools menu 
click Rotate 3D or Move camera to position the chart to 
an appropriate perspective. 
 
To turn the display of particle numbers in the image on or 
off, select or clear the Label check box. Note that particle 
numbers are displayed for all particles which are selected 
and have their position determined on any image.  
 
Use Thickness text box to enter the number of adjacent 
images, where dimmer circular marks will be visible. This 
tool prevents multiple markings of the same particle, which 
may be visible in adjacent images. In this text box enter 
the thickness of particles measured as the number of 
consecutive images in 3D stack.  
 
R, G and B buttons enable turning on and off each color 
channel in the image.  
 
If the Zoom on check box is checked, dragging with the left mouse button pressed 
will zoom the image to the specified rectangle. Uncheck the box to proceed with the 
particle tracking and analysis.  
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2.2 Menus 
Menus are also accessible via keyboard commands as follows: 

• File (alt-F) 
• Edit (alt-E) 
• View (alt-V) 
• Mark (alt-M) 
• Help (alt-H) 

 

2.2.1 File Menu 

Import images  

Click Import images in the File menu to import a series of images. Input the number 
of images to import and input the path and name of the folder where the series of 
images is stored. To browse for the location of the folder, click the Browse button. 
When ready, press the Load button. If you entered the number of images which is 
lower than the number of all available images, you will be prompted: “Number of 
images in this directory is larger than the number of selected images. Do you want to 
input all images?” If you do not input the number of images to import, all images in 
the folder will be imported.  
 
The images should be in the 24-bit RGB color tagged image file format (TIFF). Only 
one series of images should be stored in one directory.  
 

Load positions 

If you previously analyzed the same set of images and saved the results to a 
positions file, you can open the saved positions and continue to count particles or to 
analyze results. To successfully load positions, you should not modify the positions 
file by using any other software.  
 

Save positions file 

After counting particles, you can save coordinates of all particles in all images in the 
ASCII text file by using the Save positions file option in the File menu. The first 
column is the particle number. The coordinate data is organized in the next three 
columns as triplets for x, y and z positions of the particle in the image. The origin of 
the coordinates is the top left corner of the image. The second column in the file 
represents the horizontal distance (x) of the particle, the third column represents the 
vertical distance (y) of the particle and the fourth column represents the number of 
the image or the z position. Units are pixels.  
Data can be imported in any numerical or text editing software which supports import 
of ASCII text files.  
 

Save positions file as 

If you want to save trajectories file under a different file name or to save them to a 
different location on your storage device, you can use the Save positions file as 
option in the File menu.  
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Export AVI 

A sequence of images together with their trajectories can be exported into the AVI 
video file format. After selecting the Export AVI option, a new window is opened in 
which you can set the time interval of the movie (the first and last images of the 
movie), destination directory and filename under which the AVI file will be stored, and 
the frame rate (speed) of playback of the movie.  
 

 
 
 

Exit  

Closes the ParticleCO program. 
 

2.2.2 Edit Menu 

Copy all positions 

Copies all coordinates of all particles in all images in Windows clipboard as ASCII 
text. The first column is the particle number. The coordinate data is organized in the 
next three columns as triplets for x, y and z positions of the particle in the image. The 
origin of the coordinates is the top left corner of the image. The second column in the 
file represents the horizontal distance (x) of the particle, the third column represents 
the vertical distance (y) of the particle and the fourth column represents the number 
of the image or the z position. Units are pixels.  
Data can be pasted into any numerical or text editing software. In frame positions 
where coordinates of a certain particle are not determined, the “NaN” sign is inserted.  
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2.2.3 View Menu 

View/hide labels  

Toggles display of numerical labels of tracked particles. Labels appear next to the 
center of the particle.  

View 3D positions  

Opens a separate window with 3D display of all coordinates.  

 

 

2.2.4 Mark Menu 

Clear current position 

Use this option to clear coordinates of the selected particle in the current image. You 
can also use the Left arrow shortcut key.  
 

Clear all 

Use this option to clear coordinates of all particles in all images.  
 

Next frame 

Use this option to proceed to the next image frame. You can also use the Up arrow 
shortcut key or click up the scroll arrow on the slider.  
 

Previous frame 

Use this option to go to the previous image frame. You can also use the Down arrow 
shortcut key or click the down scroll arrow on the slider. 
 

Play 

Use this option to present all time frames as an on screen movie. Press Esc key to 
stop the play.  
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2.2.8 Help Menu 
The Help menu provides access to the ParticleCO Help files. 

 

 
 

Frequently asked questions 
The Enter shortcut key does not enable manual selection of particle coordinates.  
 
The Enter, Right arrow and Left arrow shortcut keys are active only if an image 
window is selected (active). To select an image window, click with the left mouse 
button into the image. If the cursor is in any other window, slider or textbox, shortcut 
keys are not functional.  
 
When I use the Play option, I am unable to stop playback of the image display.  
 
To stop playback, use the Esc key on keyboard.  
 
How can I change the position of one individual particle? 
 
To change the position of an individual particle first check Label checkbox to identify 
the particle. Than enter the particle number into the Enter particle No. edit box, than 
press Enter and click with the left mouse button to the new position.  
 
 


